martedì 22 marzo 2011

SOMMASE - Come si utilizza SUMIF - Come funziona SOMMASE

La funzione SOMMASE - SUMIF, consente di fare la somma di una colonna, o tabella solo dei dati che rispettano una determinata condizione da noi decisa.



Esempio:
Vogliamo fare la somma di una colonna ( ma poteva anche essere una tabella ), di solo i numeri positivi escludento quelli con il segno meno.
Quindi
1) Determiniamo il range o meglio l'intervallo di caselle da analizzare.
2) Determiniamo la condizione >0 ( maggiore di zero, quindi positivo )
3) Su quale colonna deve fare la somma ( in questo caso la stessa ) .
Quindi il risultato, è 15 perchè esclude -1 perchè è negativo e non rispetta la condizione >0 maggiore di zero.

Questa funzione puo anche essere applicata a tabelle più complesse e con molti dati.
Un esempio è una tabella con due colonne, dove nella prima ci sono nomi che si ripetono, e nella seconda colonna ci sono delle cifre associate al nome.
Grazie a questa funzione è possibile fare la somma di tutte le cifre associate a un solo nome .
Quindi:
1) Selezioniamo tutto lo spazio che ci interessa, D8 e E25.
2) Stabiliamo il criterio, anziche scriverlo direttamente indichiamo una casella, cosi il sistema utilizzerà come criterio quello che scriveremo nella casella G8.
3) Determinare quale è l'area dove fare la ricerca e le somme delle cifre che rispettano il criterio E8:E25.

 
Quindi noi abbiamo scritto nella casella G8 "Paolo", e la funzione fà la somma di tutte le cifre della colonna E che si riferiscono al nome PAOLO della colonna D.
Se nella colonna G8 scriviamo un'altro nome esempio MARCO, la funzione immediatamente fà la somma delle cifre corrispondenti a MARCO, e cosi via.



E' molto utile e molto utilizzata .

Somma le celle specificate secondo un criterio assegnato.
Sintassi
SOMMA.SE(intervallo;criteri;int_somma)
Intervallo   è l'intervallo di celle che si desidera calcolare in base ai criteri. Le celle in ogni intervallo devono contenere numeri o nomi, matrici o riferimenti che contengono numeri. Le celle vuote e i valori di testo verranno ignorati.
Criteri   sono i criteri in forma di numeri, espressioni o testo che determinano le celle che verranno sommate. Ad esempio, è possibile esprimere i criteri come 32, "32", ">32" oppure "mele".
Int_somma   sono le celle effettive da sommare se le celle corrispondenti in intervallo soddisfano i criteri. Se int_somma viene omesso, le celle nell'intervallo verranno sia calcolate in base ai criteri sia sommate nel caso soddisfino i criteri.
Osservazioni
  • Int_somma non deve necessariamente avere le stesse dimensioni e forma di intervallo. Le celle effettive sommate vengono determinate utilizzando la cella superiore sinistra di int_somma come cella iniziale e vengono quindi incluse le celle che corrispondono a intervallo in termini di dimensioni e forma. Ad esempio:
    Se intervallo èE int_somma èLe celle effettive sono
    A1:A5B1:B5B1:B5
    A1:A5B1:B3B1:B5
    A1:B4C1:D4C1:D4
    A1:B4C1:C2C1:D4
  • Nei criteri è possibile utilizzare i caratteri jolly, ovvero il punto interrogativo (?) e l'asterisco (*). Utilizzare il punto interrogativo e l'asterisco per indicare rispettivamente un carattere singolo e una sequenza di caratteri qualsiasi. Se si desidera trovare un punto interrogativo o un asterisco, digitare una tilde (~) prima del carattere.
Esempio
Per facilitare la comprensione dell'esempio, è possibile copiarlo in un foglio di lavoro vuoto.
Creare una cartella di lavoro o un foglio di lavoro vuoto.
 
1
2
3
4
5
AB
Valore proprietàCommissione
100.0007.000
200.00014.000
300.00021.000
400.00028.000
FormulaDescrizione (risultato)
=SOMMA.SE(A2:A5;">160000";B2:B5)Somma delle commissioni relative ai valori di proprietà maggiori di 160.000 (63.000)
=SOMMA.SE(A2:A5;">160000")Somma dei valori di proprietà maggiori di 160.000 (900.000)
=SOMMA.SE(A2:A5;"=300000";B2:B3)Somma delle commissioni relative ai valori di proprietà uguali a 300.000 (21.000)


Nessun commento: