domenica 4 novembre 2012

Come fare un calendario 2013 - 2014 personalizzato con EXCEL - Un calendario personale con EXCEL

In EXCEL è possibile fare un calendario personalizzato 2013 - 2014.

Per costruire un calendario in EXCEL 2013 -2014 personalizzato , procedere come segue :

1) Iniziamo a scrivere il primo giorno di gennaio 2013 - 2014 in una casella e la formattiamo come data in modo che esca anche il giorno della settimana a cui si riferisce, in questo caso martedi .


2) Adesso copiamo in basso per almeno tre settimane in modo da ottenere appunto i giorni delle prime tre settimane , e coloriamo di verde Sabato e Domenica . 

3) Sulla colonna "E", scriviamo abbreviato il giorno della settimana corrispondente , Lun ,  Mar, Mer, Gio, Ven, Sab, Dom ..


4) Sulla colonna "C" , invece scriviamo il numero della settimana, cioe dal Lunedi alla Domenica è considerata una settimana, a fianco della quale scriviamo il numero della settimana progressivo corrispondente 1, 2 , 3 , come in questo caso .

5) In realtà quando si passa al lunedi della settimana 3, non scriviamo il numero, ma una formula che indica la casella soprastante + 1 , in modo da indicare un numero successivo a quello della settimana precedente. 


 6) Nella casella successiva, invece indichiamo il riferimento della casella soprastante e basta,  in modo da continuare con il numero della settimana uguale.


7) Adesso possiamo selezionare tutta la settimana 3 dal Lunedi alla Domenica, e posizionarci con il mouse sull'angolo in basso a destra, cliccare e trascinare in basso in modo da copiare, sia il progressivo dei giorni, sia la formattazione e anche il progressivo delle settimane, tutto in un colpo solo.



8) Adesso abbiamo ottenuto tutto il calendario 2013 in verticale .


9) Nella colonna "B", ora scriviamo la formula =C3&E3, in modo da unire il numero della settimana e il giorno corrispondente ( questo ci servirà successivamente ) .



10) Adesso creiamo un'altra tabella dove vogliamo indicare tutte le date di Lunedi del 2013, per fare questo costruiamo una tabella con 53 numeri progressivi a sinistra , e scriviamo una formula CERCAVERT, che ci trovi tutti i lunedi del 2013 estraendoli dalle colonne C e D .
Quindi scriviamo =CERCA.VERT(G5;C:D;2;O),  e la copiamo in basso .



11) Adesso prepariamo a destra la tabella del nostro calendario personalizzato , che si sviluppa ad esempio in tre blocchi , uno sotto l'altro .


12) Adesso inseriamo un comando a frecce dalla scheda SVILUPPO - INSERISCI


13) I parametri per il comando a freccia saranno , come valori da 1 a 50 e come casella H3 , sopra l'elenco delle settimane 2013.


14) Ora prepariamo le formule dei tre blocchi del calendario, come prima cosa sulla prima casella sopra il primo blocco, mettiamo come riferimento proprio H3 , cioe la settimana selezionata con il comando a frecce .


15) Invece nella casella di fianco scriviamo una formula che si riferisce alla casella di sinistra + 1, in modo da continuare il progressivo delle settimane . 


16) Invece nel blocco sotto si farà riferimento all'ultima casella sopra + 1 , per continuare anche sotto il progressivo delle settimane.


17) Ora selezioniamo tutte le caselle e le formattiamo come DATA , però personalizzata, cioè "gg mm", cioè vogliamo vedere della data solo i giorni e il mese .

18) Adesso scriviamo la formula per popolare il nostro calendario,  cioè cercheremo nella prima casella, il Lunedi della settimana 2, e sarà =CERCA.VERT(L$5&$K6;$B:$D;3;0) , i $ servono a rendere i riferimenti della formula copiabili anche nelle altre celle .


19) Quindi copiamo la formula su tutte le celle, anche nel blocco sottostante, dove però dobbiamo correggere il riferimento della settima ( in blu ), che possiamo trascinare in basso sulla corrispondente settimana 7 , oppure fare la correzione cambiando direttamente il riferimento nella formula da L5 a L14 .


 20)Adesso il nostro calendario personalizzato è pronto, basta cliccare sul comando a frecce e le settimane cambiano e anche tutti i giorni nei tre blocchi .

21) Possiamo andare avanti o indietro con la freccia ed avere una visione piuttosto ampia dei giorni, ad esempio se scorriamo con il comando a frecce fino a fare in modo che la settimana corrente corrisponda a quella in giallo, possiamo vedere ben 5 settimane precedenti e 9 settimane successive .


Oltre-10000-visitatori-mese-sul-blog

QUI ho fatto un'altro Blog che ti potrebbe interessare .

Questo come al solito è solo un esempio, applicando la stessa logica si possono fare calendari su misura per ogni anno che verrà , l'importante che rispecchino quello che vogliamo vedere quando guardiamo il nostro calendario personalizzato .

QUI un'altro esempio di calendario con EXCEL .

Come fare un calendario perpetuo

2 commenti:

fare calendari ha detto...

Finalmente una guida fatta come si deve. Erano giorni che provavo a fare calendari con Excel e non riuscivo. Grazie mille, davvero utilissimo!

La voliera senza sbarre ha detto...

Grazie a te per la visita